Upstream incident impacting PAYID transactions - 27 August 2026

Incident Report for Biz Core

Resolved

This incident has been resolved.

If you have any questions or concerns, please contact our support team at support@bizcore.com.au
Posted Aug 27, 2026 - 16:59 AEST

Monitoring

Azupay has advised that services have stabilised and the incident is now resolved.

Payments that were delayed or failed during the outage (3:04pm–3:27pm AEST) have been reprocessed.
Posted Aug 27, 2026 - 16:42 AEST

Investigating

Our upstream PayID provider, Azupay, is currently experiencing an incident affecting PayID, causing errors and delays for some payments.

Some customers may see errors or delays with incoming and outgoing payments via PayID.

Azupay is investigating the issue and we will continue to provide updates as further information becomes available.

If you have any questions or concerns, please contact our support team at support@bizcore.com.au

Thank you,
Biz Core Support Team
Posted Aug 27, 2026 - 16:21 AEST
This incident affected: Services (API) and Third-party & Platform Notices (Platform Notices (Upstream Services)).