Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 03, 2025 - 09:15 AEST
Scheduled
Hi All,
We’d like to inform you that the Biz Core platform will undergo a patch starting at 09:15 AM. During this update, the platform may be unavailable for a brief period of approximately five minutes. We expect full functionality to be restored by 09:30 AM.
Issue/s addressed in this patch: Resolved an issue affecting subscribers when merging customers within the Leads Workspace.
If you have any questions or need assistance, please don’t hesitate to contact our support team.
Thank you for your patience and continued support.
Best regards, The Biz Core Development Team
Posted Dec 03, 2025 - 08:46 AEST
This scheduled maintenance affected: Biz Core Portal, Biz Core API, Biz Core Webhooks, and Customer Portal.