Atlassian outage impacting service desk availability

Incident Report for Biz Core

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 15:00 AEST

Update

Please direct any support requests directly via email to support@bizcore.com.au
Posted Aug 27, 2026 - 14:38 AEST

Investigating

We are currently investigating this issue.
Posted Aug 27, 2026 - 14:37 AEST
This incident affected: Services (Support Center).