Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 14, 2026 - 20:00 AEST
Scheduled
Hi All,
We wanted to notify you that Biz Core platform will be undergoing maintenance tonight, starting at 8:00 PM. During this time, the platform will be unavailable for approximately 30 minutes. However, we anticipate that the platform will be fully operational by 8:30 PM.
Issues included in release: - Feature: Added the ability for users to view and download loan amortisation schedules. - Feature: Added bank statement refresh support to the Create Lead and Create Loan APIs for Illion and Credit Sense. - Feature: Added a new API endpoint for uploading signed Direct Debit Authority documents to authorise the related source and agreement. - Feature: Standardised application decline and withdraw reasons using searchable predefined dropdowns, with “Other” supporting mandatory additional details. - Fix: Removed excess spacing from Loan Product email templates so emails sent from Biz Core now better match the formatting shown in the editor. - Fix: Ensured the Customer Contacts snapshot in the Loans workspace matches the Loan Details screen after customer contact information is updated. - Fix: Fixed scheduled payment editing so the Scheduled Payment Amount displays in the correct field. - Fix: Updated the existing agreement source direct debit update flow so authorisation is handled only through the new DDA upload process. - Fix: Updated Application Summary so selected decline and withdraw reasons display clearly, including truncated “Other” values with full text available on hover. - Fix: Ensured manual agreement creation communication flags no longer affect card authorisation notifications.
If you have any further questions, please don't hesitate to contact our support team.
Thank you for your patience and continued support.
Best regards, Biz Core Dev Team
Posted May 14, 2026 - 16:29 AEST
This scheduled maintenance affected: Biz Core Portal, Biz Core API, and Customer Portal.