Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 27, 2025 - 01:00 AEST
Scheduled
Hi All,
Our upstream payment partner, Azupay, will be performing scheduled maintenance on Thursday, 27 March 2025, from 1:00 am to 5:00 am AEST (QLD Time).
During this window, there may be intermittent interruptions of less than 60 seconds to PayID top-ups and disbursements. Any affected transactions will be automatically queued and retried, which may result in a slight delay of a few minutes.
No action is required. If you have any questions or concerns, please contact our support team.
Thank you, Biz Core Support Team
Posted Mar 21, 2025 - 09:47 AEST
This scheduled maintenance affected: Services (Azupay (PayID)).