System Performance — Service Degradation

Incident Report for Biz Core

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 13:41 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2026 - 11:38 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 18, 2026 - 09:54 AEST

Investigating

Dear Subscribers,

We are currently experiencing temporary system slowness and degraded performance across some services which we are actively investigating as a high priority.

We appreciate your patience and apologize for any inconvenience caused, and will continue updating as thing progress.

Thank you,
Biz Core Support Team
Posted Feb 18, 2026 - 09:07 AEST
This incident affected: Biz Core Portal.