Active Investigations & Fixes in Progress

Incident Report for Biz Core

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 12:34 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2025 - 06:15 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 15, 2025 - 10:26 AEST

Investigating

Impact: Some loan operations, ledger loading, and payment scheduling.

🧭 Current Known Issues Under Investigation
• Ledger Load Failures (Loan API Errors)
•Affected loans are failing to load ledger data due to the following backend errors:
   Invalid payment frequency.
   Value was either too large or too small for a Decimal.
 • ✅ QA has reproduced the issue and a fix is being implemented.

• Missing Direct Debit Schedule After Payment
 • A payment was recorded, but the remaining direct debit schedule disappeared unexpectedly.
 • 🔍 We're currently investigating whether a rule or backend recalculation caused the removal.

🛡️ What We're Doing:
• Triage and hotfix development is in progress
• Affected services are being monitored via Application Insights and Rollbar
• High-priority cases are being escalated to the dev team
• Improvements to validation, schedule generation, and error handling are being prioritised

🛠️ Planned Fix Deployment
• A patch deployment is scheduled for tonight at 8:00 PM AEST
• This patch includes fixes for:
  • Repayment frequency logic
  • Decimal overflow in compound interest calculations
  • Ledger and future scheduling behaviour.
• We will monitor system health closely post-deployment and confirm resolution with impacted users

✅ What You Can Expect:
• Affected features should return to normal functionality after tonight’s release
• Subscribers will be notified once the patch is live
• No manual action is required from your end

We sincerely apologise for any inconvenience and appreciate your patience as we work to resolve these issues promptly.

The BizCore Team
Posted Apr 15, 2025 - 10:25 AEST
This incident affected: Third-party & Platform Notices (Platform Notices (Upstream Services)).