Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 30, 2025 - 12:30 AEST
Scheduled
Hi all,
We’d like to inform you that the Biz Core platform will undergo urgent maintenance starting at 12:30 PM today. During this time, a brief outage of approximately 5–10 minutes is expected while we deploy a patch addressing the following issue:
Issue resolved in this patch:
Bug fix: Corrected an error that caused an additional record to be created when editing and saving affordability items in the application form.
If you have any questions, please don’t hesitate to contact our support team.
Thank you for your patience and continued support.
Best regards, Biz Core Development Team
Posted Oct 30, 2025 - 12:11 AEST
This scheduled maintenance affected: Biz Core Portal, Biz Core API, Biz Core Webhooks, and Customer Portal.