A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2025 - 11:49 AEST
Investigating
Hi All,
We have been notified by our upstream payment partner, Azupay, that outbound PayID disbursements to some Commonwealth Bank (CBA) customers are currently failing.
Azupay is investigating the issue and working to confirm whether other banks are affected. We will continue to provide updates as further information becomes available.
If you have any questions or concerns, please contact our support team at support@bizcore.com.au
Thank you, Biz Core Support Team
Posted Sep 17, 2025 - 10:48 AEST
This incident affected: Services (Azupay (PayID)).