Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 10, 2025 - 02:00 AEST
Scheduled
Hi All,
Our upstream payment partner, Azupay, will be performing scheduled maintenance on Thursday, 10 April 2025, from 2:00 am to 6:00 am AEST.
During this window, there may be intermittent interruptions of less than 60 seconds to PayID top-ups and disbursements. Any affected transactions will be automatically queued and retried, which may result in a slight delay of a few minutes.
No action is required. If you have any questions or concerns, please contact our support team.
Thank you, Biz Core Support Team
Posted Apr 07, 2025 - 14:09 AEST
This scheduled maintenance affected: Services (Azupay (PayID)).