Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 24, 2025 - 16:30 AEST
Scheduled
Hi All,
We wanted to notify you that Biz Core platform will be undergoing maintenance this afternoon, starting at 4:30 PM. During this time, the platform will be unavailable for approximately 15-20 minutes. However, we anticipate that the platform will be fully operational by 4:50 PM.
Issues included in patch: -An issue related to Google Maps Address Autofill where the address did not correctly fill out all fields leading to a validation error.
If you have any further questions, please don't hesitate to contact our support team.
Thank you for your patience and continued support.
Best regards, Biz Core Dev Team
Posted Jul 24, 2025 - 15:45 AEST
This scheduled maintenance affected: Biz Core Portal, Biz Core API, Biz Core Webhooks, and Customer Portal.